hdu5045 Contest 狀壓DP

Contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1669    Accepted Submission(s): 669


Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems. 

On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more. 

Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems. 

For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij .

At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal. 

You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
 

Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.

The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.

The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
 

Sample Input
1 2 3 0.6 0.3 0.4 0.3 0.7 0.9
 

Sample Output
Case #1: 2.20000
 


發現其實每個人的做題情況的要求,具有模2的性質,即不能比別人多做兩道題,可以用二進制串進行狀態壓縮,使用一個長度爲n的二進制串,每一位表示到當前爲止那個人相對於上一輪是否做過題,如果他已經做過一次了,就暫時不再讓他做,再讓他做就會出現例如100201的情況,做2個題的人比做0個題的人要多做兩個題,這裏說的0,1,2都是相對於上一輪的,並不是絕對的數量


dp[i][t]爲做到第i個題,人的做題狀況爲t時達到的最大概率和


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

double dp[1005][10005];
double p[15][1005];

int n, m, T, kase;

int main()
{
	cin >> T;
	kase = 0;
	while (T--) {
		scanf("%d%d", &n, &m);
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= m; j++) {
				scanf("%lf", &p[i][j]);
			}
		}
		int lim = (1 << n) - 1;
		for (int i = 0; i <= m; i++) {
			for (int j = 0; j <= lim; j++) {
				dp[i][j] = -1.0;   //標記不不可能存在的狀態爲-1
			}
		}
		//for (int i = 0; i <= lim; i++) dp[0][i] = 0; //debug
		dp[0][0] = 0.0;
		for (int i = 1; i <= m; i++) {  //每個題
			for (int k = 0; k <= lim; k++) {  //到前一道題爲止每個人的答題狀況
				if (dp[i - 1][k] < 0.0) continue; //debug 前一種狀態不存在,繼續遍歷查找
				for (int j = 0; j < n; j++) { //每個人
					int t = (1 << j);
					if (!(t & k)) {
						t = t | k;  //做這個題,更新做題狀況
						if (t == lim) t = 0;  //每個人都做了一道題,重新開始輪
						dp[i][t] = max(dp[i][t], dp[i - 1][k] + p[j + 1][i]);
					}
				}
			}
		}
		double ans = 0.0;
		for (int i = 0; i <= lim; i++) {
			ans = max(ans, dp[m][i]);
		}
		printf("Case #%d: %.5f\n", ++kase, ans);
	}
	return 0;
}


發佈了198 篇原創文章 · 獲贊 8 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章