POJ2239:Selecting Courses

點擊打開題目鏈接


Selecting Courses

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7814   Accepted: 3463

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects. 

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him? 

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

Source

POJ Monthly,Li Haoyuan


=====================================題目大意=====================================


給出N門課程每週學生能夠的學習時間,幫助LiMing計算一週最多能選擇多少互不衝突的課程學習。


=====================================算法分析=====================================


裸二分圖最大匹配。


=======================================代碼=======================================




#include<stdio.h>
#include<string.h>

int N,M,Linker[305];

bool Edge[305][305],Vis[305];

bool DFS(int U)
{
	for(int v=0;v<=M;++v)
	{
		if(Edge[U][v]&&!Vis[v])
		{
			Vis[v]=true;
			if(Linker[v]==-1||DFS(Linker[v])) 
			{
				Linker[v]=U;
				return true;
			}
		}
	}
	return false;
}

int Hungary()
{
	memset(Linker,-1,sizeof(Linker));
	int ans=0;
	for(int u=0;u<N;++u)
	{
		memset(Vis,0,sizeof(Vis));
		if(DFS(u)) { ++ans; }
	}
	return ans;
}

void ReaData()
{
	M=0;
	memset(Edge,0,sizeof(Edge));
	for(int i=0;i<N;++i)
	{
		int t,p,q;
		scanf("%d",&t);
		while(t--)
		{
			scanf("%d%d",&p,&q);
			int index=(p-1)*12+(q-1);
			Edge[i][index]=1;
			M=(M>index?M:index);
		}
	}
}

int main()
{
	while(scanf("%d",&N)==1)
	{
		ReaData();
		printf("%d\n",Hungary());
	}
	return 0;
}

發佈了111 篇原創文章 · 獲贊 0 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章