PAT_1037: Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
備註:典型的貪心算法。兩個數組降序排序一下,設兩個指針,先從頭算,兩個都爲正則將乘積加入到最大和裏;然後兩個指針從尾開始,兩個都爲負則將乘積加入到最大和裏。

#include<stdio.h>
#include<stdlib.h>

#define MAXSIZE 100000

int compare(const void *a,const void *b)
{
	int a1 = *(int *)a;
	int b1 = *(int *)b;

	return b1-a1;
}


int main()
{
	int NC,NP;
	int a[MAXSIZE],b[MAXSIZE];
	long long MaxMoney=0;

	scanf("%d",&NC);
	for(int i=0;i<NC;i++)
		scanf("%d",&a[i]);
	scanf("%d",&NP);
	for(int i=0;i<NP;i++)
		scanf("%d",&b[i]);

	//sort non-increasing
	qsort(a,NC,sizeof(int),compare);
	qsort(b,NP,sizeof(int),compare);

	for(int i=0,j=0;i<NC && j<NP;i++,j++)
	{
		if(a[i]>0 && b[j]>0)
			MaxMoney+=a[i]*b[j];
	}

	for(int i=NC-1,j=NP-1;i>=0 && j>=0; i--,j--)
	{
		if(a[i]<0 && b[j]<0)
			MaxMoney+=a[i]*b[j];
	}

	printf("%d",MaxMoney);
	return 0;
}
	
發佈了58 篇原創文章 · 獲贊 0 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章