PAT_1054: The Dominant Color

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
備註:直接用map就過了,注意還是要用scanf,printf進行輸入輸出,否則會超時。
#include<stdio.h>
#include<map>
using namespace std;


int main()
{
	int M,N;
	scanf("%d %d",&M,&N);

	map<int,int> Mymap;

	for(int i=0;i<M*N;i++)
	{
		int p;
		scanf("%d",&p);
		if(Mymap.count(p)==0)
			Mymap[p]=1;
		else
			Mymap[p]++;
		if(Mymap[p]>M*N/2)
		{
			printf("%d",p);
			return 0;
		}
	}

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章