PAT_1027: Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456
備註:簡單題。注意0的情況。
#include<stdio.h>

void TransformAndPrint(int n)
{
	if(n==0)
	{
		printf("00");
		return;
	}
	int s[2];
	int i=1;
	while(n>0)
	{
		s[i--]=n%13;
		n=n/13;
	}
	if(i==0)
		s[i]=0;
	for(i=0;i<2;i++)
	{
		if(s[i]>=0 && s[i]<=9)
			printf("%d",s[i]);
		else
			printf("%c",s[i]-10+'A');
	}
}

int main()
{
	int a,b,c;
	scanf("%d %d %d",&a,&b,&c);

	printf("#");
	TransformAndPrint(a);
	TransformAndPrint(b);
	TransformAndPrint(c);

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章