PAT_1028: List Sorting

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
備註:簡單題,直接上qsort即可,寫三個compare函數搞定。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

typedef struct record
{
	char id[10],name[20];
	int grade;
}STU;

int compare1(const void *a,const void *b)
{
	STU st1 = *(STU *)a;
	STU st2 = *(STU *)b;

	return strcmp(st1.id,st2.id);
}

int compare2(const void *a,const void *b)
{
	STU st1 = *(STU *)a;
	STU st2 = *(STU *)b;

	if(strcmp(st1.name,st2.name)==0)
		return strcmp(st1.id,st2.id);
	return strcmp(st1.name,st2.name);
}

int compare3(const void *a,const void *b)
{
	STU st1 = *(STU *)a;
	STU st2 = *(STU *)b;

	if(st1.grade==st2.grade)
		return strcmp(st1.id,st2.id);
	return st1.grade-st2.grade;
}

int main()
{
	int N,C;
	STU *stu_list;
	scanf("%d %d",&N,&C);

	stu_list = new STU[N];
	for(int i=0;i<N;i++)
		scanf("%s %s %d",stu_list[i].id,stu_list[i].name,&stu_list[i].grade);

	if(C==1)
		qsort(stu_list,N,sizeof(STU),compare1);
	else if(C==2)
		qsort(stu_list,N,sizeof(STU),compare2);
	else
		qsort(stu_list,N,sizeof(STU),compare3);

	for(int i=0;i<N;i++)
		printf("%s %s %d\n",stu_list[i].id,stu_list[i].name,stu_list[i].grade);

	delete stu_list;
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章