PAT_1039: Course List for Student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
備註:一開始就想到用哈希的思想,直接用map容器好了,以name爲key,course list的vector爲value,結果最後一個case超時。改進思路是將name哈希爲1個整數再用map,結果順利AC。最後一個case 190ms過也是相當驚險!
#include<stdio.h>
#include<vector>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std;

int HashByName(char *s)
{
	return (s[0]-'A')*26*26*10+(s[1]-'A')*26*10+(s[2]-'A')*10+(s[3]-'0');
}

int main()
{
	int nQuery,nCourse;
	map<int,vector<int>> Mymap;

	scanf("%d %d",&nQuery,&nCourse);

	for(int i=0;i<nCourse;i++)
	{
		int CourseIdx, nStu;
		scanf("%d %d", &CourseIdx,&nStu);
		for(int j=0;j<nStu;j++)
		{
			char name[20];
			scanf("%s",name);
			int index = HashByName(name);
			Mymap[index].push_back(CourseIdx);
		}
	}

	for(int i=0;i<nQuery;i++)
	{
		char qname[20];
		scanf("%s",qname);
		int index = HashByName(qname);
		vector<int> courseList = Mymap[index];
		if(courseList.size()>0)
		{
			sort(courseList.begin(),courseList.end());
			printf("%s %d ",qname,courseList.size());
			for(int j=0;j<courseList.size();j++)
			{
				if(j==courseList.size()-1)
					printf("%d\n",courseList[j]);
				else
					printf("%d ",courseList[j]);
			}
		}
		else
		{
			printf("%s 0\n",qname);
		}
	}

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章