Red and Black (深度優先搜索 DFS)

G - Red and Black
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
….#.
…..#
……
……
……
……
……

@…

.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
這道題和Oil Deposits差不多,無非是上一道題深搜的方向有 八個,而這一道題只有四個

# include <cstdio>
# include <iostream>
# define MAXN 30
using namespace std;
int dir[4][2] = {{1,0},{0,1},{0,-1},{-1,0}};//定義四個方向
char a[MAXN][MAXN] = {0};
int n,m,sum = 0;
char ch;
void dfs (int i, int j)
{
    sum ++;
    a[i][j] = '#';
    for (int q=0; q<4; ++q)
    {
        int dx,dy;
        dx = i + dir[q][0];
        dy = j + dir[q][1];
        if(dx<n && dy<m && dx>=0 && dy>=0 && a[dx][dy] == '.')
            dfs(dx,dy);
    }
}
int main ()
{
    while (scanf ("%d %d%c",&m,&n,&ch) != EOF && m != 0 && n!= 0)
    {
        int x,y;
        for (int i=0; i<n; ++i)
        {
            for (int j=0; j<m; ++j)
            {
                scanf ("%c",&a[i][j]);
                if (a[i][j] == '@')
                {
                    x = i;
                    y = j;
                }
            }
            getchar();
        }
        sum = 0;
        dfs(x,y);
        printf ("%d\n",sum);
    }

    return 0;
}
發佈了33 篇原創文章 · 獲贊 2 · 訪問量 7612
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章