Oil Deposits(深度優先搜索DFS)

F - Oil Deposits
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2

# include <cstdio>
# include <cstring>
using namespace std;
# define MAXN 120
int visit[MAXN][MAXN] = {0};//記錄點是否已經被訪問
int dir[8][2]={{1,1},{1,-1},{1,0},{0,1},{0,-1},{-1,0},{-1,1},{-1,-1}};//定義點的方向
char b[MAXN][MAXN];
int n,m;
void dfs (int i,int j)
{
    int dx, dy, x;
    visit[i][j] = 1;
    for (int x=0; x<8; ++x)
    {
        dx = i + dir[x][0];
        dy = j + dir[x][1];
        if (b[dx][dy] != '@')//如果點不是‘@’則繼續訪問相鄰的點
            continue;
        if (visit[dx][dy])//如果點已經被訪問則繼續訪問相鄰的點
            continue;
        dfs(dx, dy);//從這個點開始進行深度優先搜索
    }
}
int main ()
{
    while (scanf ("%d %d",&n,&m) != EOF && n!= 0 && m != 0)
    {
        int sum = 0;
        for (int i=0; i<n; ++i)
             scanf ("%s",b[i]);

        for (int i=0; i<n; ++i)
            for (int j=0; j<m; ++j)
        {
            if (b[i][j] == '@' && visit[i][j] != 1)
            {

                dfs (i, j);
                 sum ++;
            }

        }
        printf ("%d\n",sum);
        memset (b, 0, sizeof (b));
        memset (visit, 0, sizeof(visit));
    }


    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章