POJ 2478(歐拉函數)

POJ 2478(歐拉函數)

Time Limit: 1000MS Memory Limit: 65536K

題意:找出1到n裏面有多少對互質的數。
歐拉函數打表即可,時間O(log n*n)。
原題:

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Source

POJ Contest,Author:Mathematica@ZSU


代碼:
#include<iostream>
using namespace std;
int a[1000001],n=1000000,b;
long long ans[1000001]={0};
void inint()
{
for(int i=1;i<=n;i++)a[i]=i;
for(int i=2;i<=n;i++)
if(a[i]==i)
for(int j=i;j<=n;j+=i)a[j]=a[j]/i*(i-1);
}
int main()
{
inint();
for(int i=2;i<=1000000;i++)ans[i]=ans[i-1]+a[i];
while(cin>>b&&b)cout<<ans[b]<<endl;
return 0;
}

發佈了33 篇原創文章 · 獲贊 13 · 訪問量 4614
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章