POJ 3090(歐拉函數)

Visible Lattice Points

Time Limit: 1000MS   Memory Limit: 65536K

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

 

 

代碼:

 

#include<iostream>
using namespace std;
int a[1005]= {0};
long long ans[1005]= {0};
void inint() {
    for(int i=1; i<=1000; i++)a[i]=i;
    for(int i=2; i<=1000; i++)if(a[i]==i)for(int j=i; j<=1000; j+=i)a[j]=a[j]/i*(i-1);
}
int main() {
    inint();
    int n,i,x;
    for(int i=2; i<=1000; i++)ans[i]=ans[i-1]+a[i];
    cin>>n;
    for(i=1; i<=n; i++) {
        cin>>x;
        cout<<i<<' '<<x<<' '<<(ans[x]+1)*2+1<<endl;
    }
    return 0;
}
發佈了33 篇原創文章 · 獲贊 13 · 訪問量 4610
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章