POJ 2342 Anniversary party(樹形DP)

原題地址

Anniversary party
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7291   Accepted: 4195

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5


樹形DP,實際上就像是把入門級的數塔放在了樹上。


記dp[ i ][ 0 ]爲 i 不去的下屬的最大活躍度和。

記dp[ i ][ 1 ]爲 i 去的時候,i 及其下屬的最大活躍度和。


若 j 爲 i 的直接下屬。

dp[ i ][ 1 ] = dp[ j ][ 0 ] //  如果 i 去了,她的直接下屬 i 不能去。

dp[ i ][ 0 ] = max ( dp[ j ][ 1 ] ,dp[ j ][ 0 ] )  //如果 i 不去,那她的直接下屬可以去或者不去。


我們從葉子節點開始,一直向根節點進行決策。



AC代碼:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int par[6066];
bool vis[6066];
int dp[6066][3];
int n;

void init(int n)
{
    for(int i=1;i<=n;i++)
    {
        par[i]=i;//初始化i的父節點爲i(我參考的並查集的寫法)
        vis[i]=0;//檢查i是否已經進行過決策
        dp[i][1]=0;
        dp[i][0]=0;
    }
}
void dfs(int root)
{
    vis[root]=1;
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&par[i]==root)
        {
            dfs(i);//dfs要在前,更新DP要在後。因爲我們是從葉子節點開始的。
            dp[root][1]+=dp[i][0];
            dp[root][0]+=max(dp[i][0],dp[i][1]);
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        init(n);
        int a,b;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&dp[i][1]);
        }
        while(scanf("%d%d",&a,&b)&&(a||b))
        {
            par[a]=b;
        }
        int root=1;
        while(par[root]!=root)
        {
            root=par[root];
        }
        dfs(root);
        printf("%d\n",max(dp[root][1],dp[root][0]));
    }
    return 0;
}


我們從葉子節點開始。
發佈了51 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章