hdu 5455__Fang Fang

Fang Fang

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 987    Accepted Submission(s): 415


Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence F of strings.
F0 = f",
F1 = ff",
F2 = cff",
Fn = Fn1 + f", for n > 2
Write down a serenade as a lowercase string S in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in F, or nothing could be done but put her away in cold wilderness.
 

Input
An positive integer T, indicating there are T test cases.
Following are T lines, each line contains an string S as introduced above.
The total length of strings for all test cases would not be larger than 106.
 

Output
The output contains exactly T lines.
For each test case, if one can not spell the serenade by using the strings in F, output 1. Otherwise, output the minimum number of strings in F to split Saccording to aforementioned rules. Repetitive strings should be counted repeatedly.
 

Sample Input
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
 

Sample Output
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1 Case #8: -1
Hint
Shift the string in the first test case, we will get the string "cffffcfffcff" and it can be split into "cffff", "cfff" and "cff".
 

Source
 
寫的有點醜= =
#include<cstring>
#include<cstdio>
char ch[1000000+10];
int main()
{
    int T,cas=1;
    scanf("%d%*c",&T);
    while(T--) {
        gets(ch);
        int len=strlen(ch);
        if(len==0) {
            printf("0\n");
            continue;
        }
        int ok=1,flag=0,ans=0,flag1=0,cnt=0;
        for(int i=0;i<len;i++) {
            if(ch[i]=='f'&&flag1==0) {
                cnt++;
            }
            if(ch[i]!='c'&&ch[i]!='f') {
                ok=0;
                break;
            }
            if(ch[i]=='c') {
                ans++;
                if(flag<=1&&flag1!=0) {
                    ok=0;//printf("//%d %d\n",flag,cnt);
                    break;
                }
                flag=0;flag1=1;
            }
            else if(ch[i]=='f') {
                flag++;
            }
        }
        if(flag1==0) {
            ans=(len+1)/2;
        }

        if(flag+cnt<=1) {
            ok=0;
        }
        printf("Case #%d: ",cas++);
        if(!ok) {
            printf("-1\n");
        }
        else
            printf("%d\n",ans);
    }
    return 0;
}


發佈了51 篇原創文章 · 獲贊 1 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章