poj 3692 (二分圖最大團)

Kindergarten
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4026   Accepted: 1933

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

題意:女孩子相互認識,男孩子也相互認識,男女之間有部分認識,問最多有多少人相互認識。

相關概念定理:

1.獨立集:任意兩點都不相連的頂點的集合 

2.定理:最大獨立集=頂點數-最大匹配邊數(二分圖當然也成立)

3.完全子圖:任意兩點都相連的頂點的集合(最大完全子圖即最大團)  

4.定理:最大團=原圖補圖的最大獨立集

所以根據第四條可以看出在二分圖中最大團問題可以方便解決,但在一般圖中爲NP問題。

 

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define maxm 405
int n,m,s;
int map[maxm][maxm],vis[maxm],link[maxm];//map存圖
int dfs(int t)
{
    for(int i=1;i<=m;i++)
    {
        if(vis[i]==0&&map[t][i])
        {
            vis[i]=1;
            if(link[i]==-1||dfs(link[i]))
            {
                link[i]=t;
                return 1;
            }
        }
    }
    return 0;
}
int MaxMatch()
{
    int num=0;
    memset(link,-1,sizeof(link));
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
        num++;
    }
    return num;
}
int main()
{
    int a,b,cas=1;
    while(cin>>n>>m>>s)
    {
        if(n==0&&m==0&&s==0)break;
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        map[i][j]=1;
        for(int i=0; i<s; i++)
        {
            cin>>a>>b;
            map[a][b]=0;
        }
        cout<<"Case "<<cas++<<": "<<n+m-MaxMatch()<<endl;
    }
    return 0;
}


 

發佈了99 篇原創文章 · 獲贊 3 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章