[數論]HDU 1452 Happy 2004 素因子分解+快速冪模+乘法逆元

傳送門:Happy 2004

Happy 2004

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 882    Accepted Submission(s): 620


Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
 

Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

A test case of X = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, in a separate line, please output the result of S modulo 29.
 

Sample Input
1 10000 0
 

Sample Output
6 10
 

Source

解題報告:

題意:給你一個n,讓你求2004^n所有因子(包括1和本身)的和%29.

題解:

s[i]代表i的所有因子之和,那麼有以下兩個結論

1、當gcd(a,b)=1時,s[a*b]=s[a]*s[b].

2、當p爲素數時,s[p^n]=p^0+p^1+……+p^n=(p^(n+1)-1)/(p-1)

知道上面的基本上就OK了

代碼如下:

#include<iostream>
#include<cstdio>
using namespace std;
long long pow_mod(long long a,long long b,long long n){
    long long res=1;
    while(b){
        if(b&1) res=res*a%n;
        a=a*a%n;
        b>>=1;
    }
    return res;
}
int main(){
    long long n;
    while(scanf("%lld",&n)&&n){
        long long a,b,c;
        a=(pow_mod(2,2*n+1,29)-1)*1%29;
        b=(pow_mod(3,n+1,29)-1)*15%29;
        c=(pow_mod(167,n+1,29)-1)*18%29;
        printf("%lld\n",(a*b*c)%29);
    }
    return 0;
}


發佈了168 篇原創文章 · 獲贊 3 · 訪問量 12萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章