HOJ 2022 Mersenne Composite Numbers

Mersenne Composite Numbers

My Tags   (Edit)
  Source : ACM ICPC Pacific Northwest 2004
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 108, Accepted : 67

One of the world-wide cooperative computing tasks is the "Grand Internet Mersenne Prime Search" - GIMPS - striving to find ever-larger prime numbers by examining a particular category of such numbers.

A Mersenne number is defined as a number of the form (2p - 1), where p is a prime number - a number divisible only by one and itself. (A number that can be divided by numbers other than itself and one are called "composite" numbers, and each of these can be uniquely represented by the prime numbers that can be multiplied together to generate the composite number - referred to as its prime factors.)

Initially it looks as though the Mersenne numbers are all primes.

Prime Corresponding Mersenne Number
2 4-1 = 3 -- prime
3 8-1 = 7 -- prime
5 32-1 = 31 -- prime
7 128-1 = 127 -- prime

If, however, we are having a "Grand Internet" search, that must not be the case.

Where k is an input parameter, compute all the Mersenne composite numbers less than 2k - where k < 63 (that is, it will fit in a 64-bit signed integer on the computer). In Java, the "long" data type is a signed 64-bit integer. Under gcc and g++ (C and C++ in the programming contest environment), the "long long" data type is a signed 64-bit integer.


Input

Input contains a single number, without leading or trailing blanks, giving the value of k. As promised, k < 63.


Output

One line per Mersenne composite number giving first the prime factors (in increasing order) separate by asterisks, an equal sign, the Mersenne number itself, an equal sign, and then the explicit statement of the Mersenne number, as shown in the sample output. Use exactly this format. Note that all separating white space fields consist of one blank.

Sample Input

31
Sample Output
23 * 89 = 2047 = ( 2 ^ 11 ) - 1
47 * 178481 = 8388607 = ( 2 ^ 23 ) - 1
233 * 1103 * 2089 = 536870911 = ( 2 ^ 29 ) - 1

解題報告:

此題就是找出63以內的非梅森素數(只有11 23 29 37 41 43 47 53 59不是梅森素數)。直接找會超時,所以我就邪惡的打表了。代碼如下:

#include<stdio.h>
int main(){
    int t;
    scanf("%d",&t);
    printf("23 * 89 = 2047 = ( 2 ^ 11 ) - 1\n");
    printf("47 * 178481 = 8388607 = ( 2 ^ 23 ) - 1\n");
    printf("233 * 1103 * 2089 = 536870911 = ( 2 ^ 29 ) - 1\n");
    printf("223 * 616318177 = 137438953471 = ( 2 ^ 37 ) - 1\n");
    printf("13367 * 164511353 = 2199023255551 = ( 2 ^ 41 ) - 1\n");
    printf("431 * 9719 * 2099863 = 8796093022207 = ( 2 ^ 43 ) - 1\n");
    printf("2351 * 4513 * 13264529 = 140737488355327 = ( 2 ^ 47 ) - 1\n");
    printf("6361 * 69431 * 20394401 = 9007199254740991 = ( 2 ^ 53 ) - 1\n");
    printf("179951 * 3203431780337 = 576460752303423487 = ( 2 ^ 59 ) - 1\n");
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章