uva 1149 Bin Packing(貪心)

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the samelength l and each item i has length li ≤ l. We look for a minimal number of bins q such that• each bin contains at most 2 items,• each item is packed in one of the q bins,• the sum of the lengths of the items packed in a bin does not exceed l.You are requested, given the integer values n, l, l1, . . . , ln, to compute the optimal number of binsq.InputThe input begins with a single positive integer on a line by itself indicating the number of the casesfollowing, each of them as described below. This line is followed by a blank line, and there is also ablank line between two consecutive inputs.The first line of the input file contains the number of items n (1 ≤ n ≤ 105). The second linecontains one integer that corresponds to the bin length l ≤ 10000. We then have n lines containing oneinteger value that represents the length of the items.OutputFor each test case, your program has to write the minimal number of bins required to pack all items.The outputs of two consecutive cases will be separated by a blank line.Note: The sample instance and an optimal solution is shown in the figure below. Items are numberedfrom 1 to 10 according to the input order.


Sample Input

1

10

80

70

15

30

35

10

80

20

35

10

30

Sample Output

6


很基礎的貪心題目,從最大的開始裝就好了

#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int w[100010];
int main()
{
    //freopen("out.txt","w",stdout);
    int t;
    cin>>t;
    while(t--)
    {
        int L,m,ans=0;
        cin>>L>>m;
        for(int i=0;i<L;i++)
        {
            cin>>w[i];
        }
        sort(w,w+L);
        int l=0,r=L-1;
        while(l<r)
        {
            if(w[r]+w[l]>m){ans++;r--;}
            else {ans++;r--;l++;}
        }
        if(r==l)ans++;
        cout<<ans<<endl;
        if(t!=0)cout<<endl;

    }
}


發佈了48 篇原創文章 · 獲贊 8 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章