ZOJ3203 Light Bulb[三分/推公式]

Light Bulb
Time Limit:1000MS     Memory Limit:32768KB

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places.

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000



題意:

首先給出T組數據,每組給出燈離地面高度H,人的身高h,燈跟牆的距離D,人站在不同位置,影子的長度都不一樣,求出最長的影子的長度。

題解:

計算出來的這條式子,可以直接進行三分,求出極值點,但是同樣,我們可以通過這條公式用O(1)的方法求出來

三分寫法:

#pragma comment(linker, "/STACK:102400000,102400000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const double esp=1e-8;
double H,h,D;
double cal(double x)
{
	return D-x+H-(H-h)*D/x;
}
double three_devide(double l,double r)
{
	double left=l,right=r,mid,midmid;
	while (left+esp<right)
	{
		mid=(right+left)/2;
		midmid=(right+mid)/2;
		if (cal(mid)>=cal(midmid))
			right=midmid;
		else
			left=mid;
	}
	return cal(right);
}
int main()
{
    int T;
	scanf("%d",&T);
	while (T--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        double l=D-h*D/H,r=D;
        double ans=three_devide(D-h*D/H,r);
        printf("%.3f\n",ans);
    }
	return 0;
}

推公式寫法:

#pragma comment(linker, "/STACK:102400000,102400000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const double esp=1e-8;
double H,h,D;
int main()
{
	int T;
	scanf("%d",&T);
	while (T--)
	{
		scanf("%lf%lf%lf",&H,&h,&D);
		double mx=D-h*D/H;
		if (D>=sqrt((H-h)*D) && mx<=sqrt((H-h)*D))
            mx=D+H-2*sqrt((H-h)*D);
		else if (sqrt((H-h)*D)<mx)
            mx=h*D/H;
        else
            mx=h;
		printf("%.3lf\n",mx);
	}
	return 0;
}

[作爲還是渣渣的我,今年第一次給新生講座講二分三分,就來寫寫了,好緊張,導致自己講的特別糟糕,感覺效果也不怎麼好,不過,還是第一次這樣呢,希望還能繼續這條路.要開始繼續努力的寫題了,爲了不讓自己留下遺憾!]


發佈了51 篇原創文章 · 獲贊 15 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章