POJ 3518 Prime Gap

Prime Gap
Time Limit: 5000MS   Memory Limit: 65536K
     

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114

#include<stdio.h>
#include<math.h>
#include<iostream>
using namespace std;
int judge(int a)
{
	if(a==0||a==1)
	{
		return 0;
	}
	int i;
	for(i=2;i<=sqrt(a+1);i++)
	{
		if(a%i==0)
		{
			return 0;
		}


	}
	return 1;

}
int main()
{
        int a,b,c;
	while(scanf("%d",&a),a)
        {
                if(judge(a)==1)
                {
                        printf("0\n");
                }
                else
                {
                        int i,j;
                        for(i=0;judge(a+i)!=1;i++)
                        for(j=0;judge(a-j)!=1;j++)

                        b=a+i+1;
                        c=a-j;
                        printf("%d\n",b-c);
                }
        }
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章