HDU 6205 card card card

card card card

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1317    Accepted Submission(s): 598


Problem Description
As a fan of Doudizhu, WYJ likes collecting playing cards very much. 
One day, MJF takes a stack of cards and talks to him: let's play a game and if you win, you can get all these cards. MJF randomly assigns these cards into n heaps, arranges in a row, and sets a value on each heap, which is called "penalty value".
Before the game starts, WYJ can move the foremost heap to the end any times. 
After that, WYJ takes the heap of cards one by one, each time he needs to move all cards of the current heap to his hands and face them up, then he turns over some cards and the number of cards he turned is equal to the penaltyvalue.
If at one moment, the number of cards he holds which are face-up is less than the penaltyvalue, then the game ends. And WYJ can get all the cards in his hands (both face-up and face-down).
Your task is to help WYJ maximize the number of cards he can get in the end.So he needs to decide how many heaps that he should move to the end before the game starts. Can you help him find the answer?
MJF also guarantees that the sum of all "penalty value" is exactly equal to the number of all cards.
 

Input
There are about 10 test cases ending up with EOF.
For each test case:
the first line is an integer n (1n106), denoting n heaps of cards;
next line contains n integers, the ith integer ai (0ai1000) denoting there are ai cards in ith heap;
then the third line also contains n integers, the ith integer bi (1bi1000) denoting the "penalty value" of ith heap is bi.
 

Output
For each test case, print only an integer, denoting the number of piles WYJ needs to move before the game starts. If there are multiple solutions, print the smallest one.
 

Sample Input
5 4 6 2 8 4 1 5 7 9 2
 

Sample Output
4
Hint
[pre] For the sample input: + If WYJ doesn't move the cards pile, when the game starts the state of cards is: 4 6 2 8 4 1 5 7 9 2 WYJ can take the first three piles of cards, and during the process, the number of face-up cards is 4-1+6-5+2-7. Then he can't pay the the "penalty value" of the third pile, the game ends. WYJ will get 12 cards. + If WYJ move the first four piles of cards to the end, when the game starts the state of cards is: 4 4 6 2 8 2 1 5 7 9 WYJ can take all the five piles of cards, and during the process, the number of face-up cards is 4-2+4-1+6-5+2-7+8-9. Then he takes all cards, the game ends. WYJ will get 24 cards. It can be improved that the answer is 4. **huge input, please use fastIO.** [/pre]
 

題意
 
    給了我們兩個數組,第一個數組對應的值減去第二個數組對應值得到一個新的值,這些值組成一個新的數組保證這個數組的值加和等於0,現在我們從第一個數開始加和,如果出現了加和小於零,抱歉,不行,但是你可以移動這些值,你可以把第一個移動到最後一個,問你最少需要移動的次數

解題思路
  
   隊友跟我說完題意之後我第一個想到的就是前綴和,我需要找到在哪一步前綴和小於零了,那麼我就需要判斷一下,在這裏移動前面所有的數字可不可以

代碼
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std ;
const int maxn = 1000000 + 10 ;
int a[maxn] , b [maxn] ;
int sum[maxn] ;
int main()
{
    int n ;
    while(scanf("%d" , &n) != EOF)
    {
        memset(sum , 0 , sizeof(sum)) ;
        for(int i = 1 ; i <= n ;i++)  scanf("%d" , &a[i]) ;
        for(int i = 1 ; i <= n ;i++)  scanf("%d" , &b[i]) ;
        int head = n + 1, tail = n + 1;
        int flag = 1 ;
        sum[0] = 0 ;
        int ans = 0 ;
        int pre= 0 ;
        for(int i = 1 ; i <= n ;i++)
        {
            sum[i] = sum[i-1] + (a[i] - b[i]) ;
            if(sum[i] < 0 && i < n)
            {
                int tt = sum[i] + a[i+1] - b[i+1] ;
                if((a[i+1] - b[i+1]) >= 0 && sum[i] - sum[pre] < 0)
                {
                    ans = i ;
                    pre = i ;
                }
            }
        }
       cout<< ans <<endl ;
    }
    return 0 ;
}


發佈了69 篇原創文章 · 獲贊 58 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章