hdu oj 2444 The Accomodation of Students-二部圖

Link:http://acm.hdu.edu.cn/showproblem.php?pid=2444

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4519    Accepted Submission(s): 2084



Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
No 3
 

代碼:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>

using namespace std;
int n,m;
const int maxn(205);
int relation[maxn][maxn];/*用於存儲兩個認識的人,
比如a b互相認識,relation[a][b],relation[b][a]均爲1,否則爲0*/
int color[maxn];//染色法判斷是否爲二部圖
int vis[maxn],link[maxn];
queue <int > q;

bool color_node()//主要是bfs跑整個圖
{
    for(int j=1; j<=n; j++)/*注意可能這個relation表示的圖爲非連通圖
        可能一共四個人a,b認識,c,d認識*/
    {
        if(color[j]==-1)
        {
            color[j]=0;
            q.push(j);
            while(!q.empty())
            {
                int now=q.front();
                q.pop();
                for(int i=1; i<=n; i++)
                {
                    if(relation[now][i])
                    {
                        if(color[i]==-1)
                        {
                            color[i]=!color[now];
                            q.push(i);
                        }
                        else if(color[i]==color[now])
                            return false;
                    }
                }
            }
        }
    }

    return true;
}
int find(int x)/*匈牙利法判斷最大匹配*/
{
    for(int i=1; i<=n; i++)
    {
        if(relation[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(!link[i]||find(link[i]))
            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int a,b;
    int sum;
    while(scanf("%d%d",&n,&m)==2)
    {

        memset(relation,0,sizeof(relation));
        memset(color,-1,sizeof(color));
        memset(link,0,sizeof(link));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            relation[a][b]=relation[b][a]=1;
        }

        if(!(color_node()))
        {
            puts("No");
            while(!q.empty())
                q.pop();
        }
        else
        {
            sum=0;
            for(int i=1; i<=n; i++)
            {
                if(!color[i])//僅從一種顏色出發,這樣可以降低複雜度,不必sum/2
                {
                    memset(vis,0,sizeof(vis));
                    sum+=find(i);
                }
            }
            cout<<sum<<endl;
        }
    }
    return 0;
}


相關連接:http://blog.csdn.net/dark_scope/article/details/8880547

這個鏈接的文章一個大神寫的,感覺很生動


發佈了37 篇原創文章 · 獲贊 6 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章