HDU2680 Choose the best route 解題報告--Dijkstra

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5249    Accepted Submission(s): 1669


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 


 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 


 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 


 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 


 

Sample Output
1 -1
 


 

Author
dandelion
 


 

Source
 


 

Recommend
lcy
#include<iostream>
#define inf 0xffff
using namespace std;
int map[1011][1011];
int mark[1011];
int dis[1011];
int n,m,s;
int Dijkstra()
{
	int i,j;
	for(i=0;i<=n;i++)
	{
		dis[i]=map[0][i];
		mark[i]=0;
	}
	dis[0]=0;
	mark[0]=1;
	for(i=0;i<n;i++)
	{
		int mimi=inf;	
		int pos=0;
		for(j=0;j<=n;j++)
		{
			if(mimi>dis[j]&&mark[j]==0)
			{
				pos=j;
				mimi=dis[j];
			}
		}
		if(mimi==inf) break;
		mark[pos]=1;
		for(j=0;j<=n;j++)
		{
			if((dis[j]>(dis[pos]+map[pos][j]))&&mark[j]==0)
				dis[j]=dis[pos]+map[pos][j];
		}
	}
	if(dis[s]==inf) return -1;
	else
		return dis[s];
}
int main()
{
	while(~scanf("%d%d%d",&n,&m,&s))
	{	
		int i,j,k;
		for(i=0;i<1011;i++)
		{
			for(j=0;j<1011;j++)
				map[i][j]=inf;		
		}
		for(i=0;i<m;i++)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
				map[a][b]=c;
		}
		int t,bb;
		scanf("%d",&t);
		for(i=0;i<t;i++)
		{
			scanf("%d",&bb);
			map[0][bb]=map[bb][0]=0;
		}	
		printf("%d\n",Dijkstra());
	}
	return 0;
}


 

發佈了58 篇原創文章 · 獲贊 4 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章