大數加法

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
    第一次寫博客就來個大數加法,可真是費了一番功夫,但無非就是模擬數學加法列豎式計算。
    先用字符數組把兩個加數當作字符串接收,再從最低位開始相加賦值到另一字符數組裏(其實可以將較短的字符串與較長的字符串從最低位相加賦值到較長的字符串裏),滿十向前進一位。
    不多說了,上代碼自行體會。
示例代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
typedef long long ll;
using namespace std;
int main()
{
    char a[1020],b[1020],c[1020];
    int n,No=1;
    scanf("%d",&n);
    while(n--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        scanf("%s %s",a,b);
        int l1=strlen(a);
        int l2=strlen(b);
        int t=0;
        while(l1>0&&l2>0)
        {
            c[t]+=a[--l1]-'0'+b[--l2]-'0';
            if(c[t]>=10)
            {
                c[t+1]+=c[t]/10;
                c[t]%=10;
            }
            t++;
        }
        while(l1>0||l2>0)
        {
            if(l1==0&&l2!=0)
            {
                c[t]+=b[--l2]-'0';
                if(c[t]>=10)
                {
                    c[t+1]+=c[t]/10;
                    c[t]%=10;
                }
            }
            else if(l1!=0&&l2==0)
            {
                c[t]+=a[--l1]-'0';
                if(c[t]>=10)
                {
                    c[t+1]+=c[t]/10;
                    c[t]%=10;
                }
            }
            t++;
        }
        printf("Case %d:\n",No++);
        printf("%s + %s = ",a,b);
        for(int i=t;i>=0;i--)
        {
            if(i==t&&c[i]!=0)
                putchar(c[i]+'0');
            if(i!=t)
            putchar(c[i]+'0');
        }
        printf("\n");
        if(n!=0)printf("\n");
    }
    return 0;
}

發佈了28 篇原創文章 · 獲贊 17 · 訪問量 6028
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章