1038 Recover the Smallest Number (30分) 因爲要求最小的序列和,故在cmp上做文章,string substr用法

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

 

#include <bits/stdc++.h>
using namespace std;
const int maxn = 10010;
vector<string>v;
int cmp(string a, string b)
{
    return a+b<b+a;
}
int main()
{
    int n;
    string s;
    cin>>n;
    for(int i=0; i<n; i++)
    {
        cin>>s;
        v.push_back(s);
    }
    string ou="", out;
    sort(v.begin(), v.end(), cmp);
    for(int i=0; i<n; i++)
    {
        ou += v[i];
    }
    int j = 0;
    for(int i=0; i<ou.size(); i++)
    {
        j=i;
        if(ou[i]!='0') break;
    }
    out = ou.substr(j);
    printf("%s\n", out.c_str());
    return 0;
}

 

發佈了59 篇原創文章 · 獲贊 4 · 訪問量 5656
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章