a1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output

2 4


最短路徑問題,dijkstra多練幾道題。。。我隔了幾天再寫中間又出問題了。


ac代碼:

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;
const int maxn=501;
const int INF=1000000000;

int n,teamnum[maxn],g[maxn][maxn],w[maxn];
int dis[maxn],num[maxn];
bool vis[maxn];
void dijkstra(int a){
  fill(dis,dis+maxn,INF);
  //fill(num,num+maxn,1);
  dis[a]=0;
  num[a]=1;
  w[a]=teamnum[a];
  int min=INF,u=-1;

  for(int j=0;j<n;j++){
    min=INF,u=-1;  
    for(int i=0;i<n;i++){
      if(vis[i]==false&&dis[i]<min){
        u=i;
        min=dis[i];
      }
    }//這裏之前括號沒打 找了半天bug 
      if(u==-1) return;
      //cout<<"u "<<u<<endl;
      vis[u]=true;
      for(int v=0;v<n;v++){
        if(vis[v]==false&&g[u][v]!=INF){
          if(dis[u]+g[u][v]<dis[v]){
            num[v]=num[u];
            dis[v]=dis[u]+g[u][v];
            w[v]=w[u]+teamnum[v];
          }
          else if(dis[u]+g[u][v]==dis[v]){
            num[v]+=num[u];
            if(w[u]+teamnum[v]>w[v]) w[v]=w[u]+teamnum[v];
          }
        }
      }
      
    }
}

int main(){
    int m,c1,c2;
    //freopen("D:\input.txt","r",stdin);
    cin>>n>>m>>c1>>c2;
    fill(g[0],g[0]+maxn*maxn,INF);
    for(int i=0;i<n;i++) cin>>teamnum[i];
    int a,b;
    for(int i=0;i<m;i++){
      cin>>a>>b;
      cin>>g[a][b];
      g[b][a]=g[a][b];
    }
    dijkstra(c1);
    
    cout<<num[c2]<<" "<<w[c2];
    
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章