HDU 5918 Sequence I kmp算法+雖然暴力也能過

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 211    Accepted Submission(s): 90


Problem Description
Mr. Frog has two sequences a1,a2,,an and b1,b2,,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,,bm is exactly the sequence aq,aq+p,aq+2p,,aq+(m1)p where q+(m1)pn and q1.
 

Input
The first line contains only one integer T100, which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1n106,1m106 and 1p106.

The second line contains n integers a1,a2,,an(1ai109).

the third line contains m integers b1,b2,,bm(1bi109).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
Case #1: 2 Case #2: 1
 

Source
2016中國大學生程序設計競賽(長春)-重現賽

解題思路:
1,字符串匹配,只是文本串每次移動p位而已
2,然後就是要注意,以前kmp做字符轉匹配的時候,模式串的p[m]位置是有'\0'的,然而變成數組的時候
要保證p[m]=0即可,也就是要memset模式串。
3,其實這題數據非常的水,當時暴力n^2的複雜度都能過。(不知道後來數據會不會加強)

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1000005 ;
int f[maxn] ;
int a[maxn] ;
int b[maxn] ;
int n,m,pp;
int ans ;
void find(int st,int *T,int *P){
    int j = 0 ;
    for(int i=st;i<n;i+=pp){
        while(j&&P[j]!=T[i]){j = f[j];}
        if(P[j]==T[i])j++ ;
        if(j==m){
            ans++ ;
            //j = 0 ;
        }
    }
}
void getfail(int *p){
    f[0] = 0 ;
    f[1] = 0 ;
    for(int i=1;i<m;i++){
        int j = f[i] ;
        while(j&&p[i]!=p[j])j = f[j] ;
        f[i+1] = (p[i]==p[j] ? j+1 : 0) ;
    }
}
int main(){
    int T,cas=1;
    scanf("%d",&T);
    while(T--){
        ans = 0 ;
        scanf("%d%d%d",&n,&m,&pp);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        for(int i=0;i<m;i++)scanf("%d",&b[i]);
        //b[m]=0;
        getfail(b) ;
        for(int i=0;i<pp;i++){
            find(i,a,b);
        }
        printf("Case #%d: %d\n",cas++,ans);
    }
    return 0;
}


發佈了104 篇原創文章 · 獲贊 3 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章