KMP POJ 1961 Period 解題報告

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 15466 Accepted: 7417
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
Source
Southeastern Europe 2004

此題是POJ 2406 Power Strings的變式:http://blog.csdn.net/dafang_xu/article/details/50780060

//5616K 250MS
#include<stdio.h>
#include<stdlib.h> 
#include<algorithm>
#include<iostream>
#include<string.h>
#define MAX 1000005 
using namespace std;
char s[MAX];
int next[MAX],len,tmp;
void getnext(){
    next[0]=-1;
    int pre=-1,suf=0;
    while(suf!=len){
        if(-1==pre||s[pre]==s[suf]) next[++suf]=++pre;
        else pre=next[pre];
    }
}
int main(){
    freopen("i.txt","r",stdin);
    int cases=0;
    while(~scanf("%d",&len)&&len&&~scanf("%s",s)){ 
        getnext();  
        cout<<"Test case #"<<++cases<<endl;
        for(int i=2;i<=len;i++){ 
            if(next[i]==0||i%(i-next[i])!=0) continue;
            tmp=i-next[i]; 
            if(i%tmp==0&&tmp!=0) 
               cout<<i<<" "<<i/tmp<<endl;
            else if(0==tmp) 
               cout<<i<<" "<<i<<endl; 
        }
        cout<<endl;
    }
    return 0;
}

歡迎留言,積極討論,一起進步!

發佈了77 篇原創文章 · 獲贊 22 · 訪問量 7萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章