HDU 1068.Girls and Boys【二分圖匹配(最大獨立集)】【5月6日】

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9926    Accepted Submission(s): 4554


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
5 2
 

要求最大獨立集。最大獨立集 = 節點數 - 最大匹配:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAX = 1005;
int Map[MAX][MAX], vis[MAX], link[MAX];
int n, a, m, b, sum;
bool PP(int node)
{
    for(int i = 0;i < n; ++i)
    {
        if(!vis[i] && Map[node][i])
        {
            vis[i] = 1;
            if(link[i] == -1 || PP(link[i]))
            {
                link[i] = node;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    while(scanf("%d", &n) != EOF)
    {
        sum = 0;
        memset(Map, 0, sizeof(Map));
        for(int i = 0;i < n; ++i) link[i] = -1;
        for(int i = 0;i < n; ++i)
        {
            scanf("%d: (%d)", &a, &m);
            while(m--)
            {
                scanf("%d", &b);
                Map[a][b] = 1;
            }
        }
        for(int i = 0;i < n; ++i)
        {
            memset(vis, 0, sizeof(vis));
            if(PP(i)) sum ++;
        }
        cout << n-sum/2 << endl;
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章