HDU 3183.A Magic Lamp【RMQ】【4月18】

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3022    Accepted Submission(s): 1174


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
13 1 0 123 321

原来这就是RMQ~给一个长度不超过1000位的数,使得删去m个数字之后剩下的部分组成的数字最小。

思路:

长度为l的数,删去m个数字之后还剩l-m位,即从l位数中选取l-m位数字使得组成的数字最小。

按顺序从最高位取,第1~m+1位中取最高位,记录取得位置为pos,则下一次从pos+1~m+2中取下一位,以此类推:


#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int MAX = 1010;
char n[MAX];
int m, l, pos, maxn, stpos, first;
int main()
{
    while(scanf("%s %d", n, &m) != EOF)
    {
        first = 1;
        l = strlen(n);
        int len = l - m;
        stpos = 0;
        if(l == m)
        {
            cout << 0 << endl;
            continue;
        }
        for(int i = 0;i < len; ++i)
        {
            maxn = 10;
            for(int j = stpos;j <= m+i; ++j)
            {
                if(n[j] - '0' < maxn)
                {
                    maxn = n[j]-'0';
                    pos = j;//记录位置
                }
            }
            if(first == 0 || i == len-1) cout << n[pos];
            else if(n[pos] != '0')//前导0不要输出
            {
                first = 0;
                cout << n[pos];
            }
            stpos = pos+1;
        }
        cout << endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章