UVa 437.The Tower of Babylon【記憶化搜索+dp】【4月25】

The Tower of Babylon

Description


Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions tex2html_wrap_inline32 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values tex2html_wrap_inline40 , tex2html_wrap_inline42 and tex2html_wrap_inline44 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Casecase: maximum height =height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

有長寬高分別爲xi,yi,hi的無數個木塊,底面長寬小於上一個則可以摞在一起。問最高能摞多高:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAX = 500;
struct ss
{
    int x, y, h;
};
ss f[MAX];
int n, k, ans, kase = 1, flag[MAX][MAX], H[MAX];
int DFS(int u)
{
    if(H[u] != -1) return H[u];//記憶化
    H[u] = f[u].h;
    for(int i = 0;i < n; ++i)
    {
        if(flag[u][i])
        {
            H[u] = max(H[u], f[u].h+DFS(i));
        }
    }
    return H[u];
}
int main()
{
    while(scanf("%d", &n) && n)
    {
        memset(H, -1, sizeof(H));
        memset(flag, 0, sizeof(flag));
        ans = 0;
        for(int i = 0;i < n; ++i)
        {
            scanf("%d %d %d", &f[i].x, &f[i].y, &f[i].h);
            f[n+i].x = f[i].x;
            f[n+i].y = f[i].h;
            f[n+i].h = f[i].y;
            f[2*n+i].x = f[i].y;
            f[2*n+i].y = f[i].h;
            f[2*n+i].h = f[i].x;
        }
        n *= 3;
        for(int i = 0;i < n; ++i)
        {
            for(int j = 0;j < n; ++j)
            {
                if((f[i].x < f[j].x && f[i].y < f[j].y) || (f[i].x < f[j].y && f[i].y < f[j].x))//表示j可以放在i上
                    flag[i][j] = 1;
            }
        }
        for(int i = 0;i < n; ++i)
        {
            ans = max(ans, DFS(i));
        }
        printf("Case %d: maximum height = %d\n", kase++, ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章