UVa10881

題目名稱:Piotr's Ants

題目鏈接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=20&page=show_problem&problem=1822


Problem D
Piotr's Ants
Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."

Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing 3 integers: L , T and n(0 <= n <= 10000). The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by nlines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before T seconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample Input Sample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R



題意:有n只螞蟻在L cm的木棍上爬行,1 cm/s,每隻螞蟻給出初設位置和爬的方向(left or right),問T時間後每隻螞蟻的位置及朝向(R ,L ,如果碰頭的就Turning,掉下去的就Fell off)


思路:從遠處看可以把螞蟻看成小黑點,那樣碰頭就可以看成直接穿過去,這樣就只要標記哪隻螞蟻在哪裏就行了


代碼:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
char z[][10]={"L","Turning","R"};
struct Ant
{
    int id,p;
    int turn;
    bool operator < (const Ant j) const
    {
        return p<j.p;
    }
};
int main()
{
    int t,n,N,L,a[10005],d[10005],f=1;
    Ant x[10005],y[10005];
    while(~scanf("%d",&N))
    {
        for(int i=0;i<N;i++)
        {
            scanf("%d%d%d",&L,&t,&n);
            for(int j=0;j<n;j++)
            {
                int p,d;
                char c;
                scanf("%d %c",&p,&c);
                d=(c=='L'?-1:1);
                x[j]=(Ant){j,p,d};
                y[j]=(Ant){0,p+t*d,d};
            }
            sort(x,x+n);
            for(int j=0;j<n;j++)
                d[x[j].id]=j; //記錄原來第幾個輸入的排序後在哪
            sort(y,y+n);
            for(int j=0;j<n;j++)
            {
                if(y[j].p==y[j+1].p)
                    y[j].turn=y[j+1].turn=0;
            }
            printf("Case #%d:\n",f++);
            for(int j=0;j<n;j++)
            {
                int a=d[j];
                if(y[a].p<0||y[a].p>L)
                    printf("Fell off\n");
                else
                {
                    printf("%d %s\n",y[a].p,z[y[a].turn+1]);
                }
            }
            printf("\n");
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章