【hdu3336】——KMP&&dp

題目:

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7511    Accepted Submission(s): 3479


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
1 4 abab
 

Sample Output
6
 

Author
foreverlin@HNU
 

Source

描述:求字符串s的長度爲i的前綴在字符串中出現的次數

題解:dp[i]表示長度爲i的前綴在字符串中出現的次數,則

<strong>dp[i] = dp[nxt[i]] + 1</strong>

代碼:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 200005;
char text[maxn];
int nxt[maxn], dp[maxn];
int main()
{
	//freopen("input.txt", "r", stdin);
	int T;
	cin >> T;
	while (T--)
	{
		int n;
		cin >> n;
		scanf("%s", text);
		for (int i = 0, j = -1; i <= n; i++, j++)
		{
			nxt[i] = j;
			while (~j && text[i] != text[j])
				j = nxt[j];
		}
		dp[0] = 0;
		/*for (int i = 0; i < n; i++)
			cout << nxt[i] << endl;*/
		for (int i = 1; i <= n; i++)
		{
			dp[i] = dp[nxt[i]] + 1;
		}
		int ans = 0;
		for (int i = 1; i <= n; i++)
		{
			ans += dp[i];
			ans %= 10007;
		}
		cout << ans << endl;
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章