【hdu2298】Toxophily——三分+二分

題目:

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1603    Accepted Submission(s): 853


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. 
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000. 
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit. 
 

Sample Input
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output
1.561582 -1 -1
 

Source



代碼:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const double eps = 1e-8;
const int maxn = 10005;
const double g = 9.8;
const double pi = acos(-1.0);
int r[maxn];
double f(double t, double x, double y, double v)
{
	return x*tan(t) - x*x*g / 2  / v / v / cos(t) / cos(t);
}
int main()
{
	//freopen("input.txt", "r", stdin);
	int T;
	scanf("%d", &T);
	while (T--)
	{
		double x, y, v0;
		scanf("%lf%lf%lf", &x, &y, &v0);
		double l = 0.0;
		double r = pi / 2;
		while (r - l > eps)
		{
			double mid1 = (l + r) / 2;
			double mid2 = (mid1 + r) / 2;
			if (f(mid1, x, y, v0) > f(mid2, x, y, v0))
				r = mid2;
			else
				l = mid1;
		}
		if (f(r, x, y, v0) < y)
		{
			puts("-1");
			continue;
		}
		l = 0.0;
		while (r - l > eps)
		{
			double mid = (l + r) / 2;
			if (f(mid, x, y, v0) > y + eps)
				r = mid;
			else
				l = mid;
		}
		printf("%.6lf\n", r);
	}
	return 0;
}
描述:給定斜拋運動的起點和目標點,求一個最小角度,使得能恰好擊中目標。

題解:考慮斜拋運動的軌跡與x = x0(即給定目標的橫座標所在直線)的交點的縱座標與theta的關係,列出函數:f(theta) = x*tan(t) - x*x*g / 2  / v / v / cos(t) / cos(t)。

畫出圖象:

發現在(0,pi/2)是單峯函數,所以使用三分法找到y的最大值,如果這個最大值都不能滿足目標則輸出-1,如果可以,則再二分找到接近y的角度,因爲要找最小的角度,所以在(0,mid)之間二分即可。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章