POJ 2406

運用KMP 的 next數組尋找串的循環節循環的最多次數



思路:KMP中的get_next(),對next數組的應用。next[len]是最後一個字符跳的步長,如果他有相同字符串,則該串長度是len-next[len],如果整個長度len能分解成x個這種串(能整除),就得到ans了。否則不能分解。只能是由他自己組成串,長度爲1。


Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 45348   Accepted: 18927

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

#include<stdio.h>
#include<string.h>
char str[1123456];
int next[1123456];
void get_next()
{
    next[0]=-1;
    int i=0;
    int j=-1;
    while(str[i]!='\0')
    {
        if(j==-1 || str[i]==str[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
        {
            j=next[j];
        }
    }
}
int main()
{
    while(~scanf("%s",str) && strcmp(str,".")!=0)
    {
        get_next();
        int len=strlen(str);
        int ans=1;
        if(len%(len-next[len])==0)
        {
            ans=len/(len-next[len]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章