hdu2955 Robberies(01揹包)題解

傳送門

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible. 


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
InputThe first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj . OutputFor each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set. 

Notes and Constraints 
0 < T <= 100 
0.0 <= P <= 1.0 
0 < N <= 100 
0 < Mj <= 100 
0.0 <= Pj <= 1.0 
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds. Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6
題意:給定一個固定概率p,要求在總風險小於p的情況下所獲得的價值最大。

其實就是一個簡單的01揹包,但是要稍微的轉換一下。一定要注意這裏的概率的精度並不是0.01,剛開始就錯誤的理解爲0.01然後wa了一發,真的好菜啊。。。

在這裏,dp[i]保存的是獲得的價值爲i時的最大安全概率,1-風險概率=安全概率,當搶 劫爲0時,安全概率爲1,所以dp[0] =1,其他的初始化爲0,分析可得狀態轉移方程爲:

dp[j] = max(dp[j] , dp[j - no[i].mi] * no[i].pi);

注意:後面的概率要相乘

#include<stdio.h>
#include<iostream>
#include<set>
#include<queue>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
double dp[100000];
struct node{
    int mi ;
    double pi;
}no[105];
int main()
{
    int t , n;
    double p;
    scanf("%d" , &t);
    while(t--){
        scanf("%lf %d" , &p , &n);
        p = 1 - p ;
        int sum = 0;
        for(int i = 1 ; i <= n ; i ++){
            scanf("%d %lf" , &no[i].mi , &no[i].pi);
            no[i].pi = 1 - no[i].pi;
            sum += no[i].mi;
        }
        memset(dp , 0 , sizeof(dp));
        dp[0] = 1;
        for(int i = 1 ; i <= n ; i ++){
            for(int j = sum ; j >= no[i].mi ; j --){
                dp[j] = max(dp[j] , dp[j - no[i].mi] * no[i].pi);
            }
        }
        for(int i = sum ; i >= 0 ; i --){
            if(dp[i] >= p){
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章