【杭電】[4707]Pet

原文地址:http://www.boiltask.com/blog/?p=1980

Pet

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.

Input
The input contains multiple test cases. Thefirst line is a positive integer T (0 < T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0< N <=100000) and D( 0 < D < N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0 <= x,y < N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.

Output
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.

Sample Input
1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

Sample Output
2

這一題感覺並查集不是很好

代碼似乎很容易出BUG

不過題目數據好像給的不是很嚴(還是很多的)

直接暴力深搜也會超時

如果dfs的話也需要先建樹

用帶權並查集的話主要是要注意

不能把0的父節點設爲其它點

#include<stdio.h>
int par[100200],ran[100200];
int find(int m) {
    if(m==par[m])
        return m;
    else {
        ran[m]+=ran[par[m]];
        return par[m]=find(par[m]);
    }

}
void unite(int x,int y) {
    if(x>y) {
        int t=x;
        x=y;
        y=t;
    }
    int a=find(x);
    int b=find(y);
    if(x==y)
        return ;
    else {
        par[b]=a;
        ran[b]=ran[x]-ran[y]+1;
    }
}
int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        int n,d;
        scanf("%d %d",&n,&d);
        for(int i=0; i<n; i++) {
            ran[i]=0;
            par[i]=i;
        }
        for(int i=1; i<n; i++) {
            int a,b;
            scanf("%d %d",&a,&b);
            unite(a,b);
        }
        int res=0;
        for(int i=0; i<n; i++) {
            if(find(i)==0&&ran[i]>d)
                res++;
        }
        printf("%d\n",res);
    }
    return 0;
}

參考博客:hdu 4707 Pet【帶權並查集】 – mengxiang000000

題目地址:【杭電】[4707]Pet

原文地址:http://www.boiltask.com/blog/?p=1980

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章