Wolf and Rabbit

Description

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 

Sample Input

2 1 2 2 2
 

Sample Output

NO YES

解題思路

歐幾里得定理,ax + by = c 當 c % gcd( a , b ) = 0 時,x , y有整數解。

所以只有當gcd( a , b ) = 1 時,c能取到任意整數,即沒有安全的洞口。



AC代碼

#include<stdio.h>
int gcd(int x, int y)
{
    if(y == 0)
        return x;
    return gcd(y, x % y);

}

int main()
{
    int T, a, b;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &a, &b);
        if(gcd(a, b) == 1)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章