hdu1536 - S-Nim (博弈 SG函數)

S-Nim

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4120    Accepted Submission(s): 1777


Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.
 

Sample Input
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
LWW WWL
 

Source
 
  //話說讀題花了好久的說,英語硬傷啊。。。

題意:
                  輸入k,並接着輸入k個集合S的元素(設置每次能取的石子數)(0 <k <=100)
                  接着輸入m,表示m種情況, (0<m<=100)
                  隨後輸入m行,每行開頭l表示堆數 隨後輸出hi,表示每堆的石子數 (0<l<=100, 0<=hi<=10000)
                  如果測試用例k = 0,結束程序

                  對於每種情況,如果該情況是勝利點,則輸出W,
                  如果是失敗點,輸出L,每次測試用例結束打印換行

 

//直接套用模版。。。

 

/***************************
*
*	acm:   hdu-1536
*
*	title: S-Nim
*
*	time:  2014.5.8
*
***************************/

//博弈論 考察SG函數


#include <stdio.h>
#include <string.h>
#include <stdlib.h>

#define MAXSIZE 1001
#define SET 101

int k;  // 集合S的元素的個數
int S[SET];  //設置每次能取的石子數
int f[10001];   //SG值 f(3) == 1 表示 sg值 == 1

//DFS 求解SG
int mex(int p)  //p 是某堆的石子數  k
{
    int i;
    int t;
    int g[101] = {0};  //記錄sg值             

    for (i = 0; i < k; i++)
    {
        t = p - S[i];  //t == 剩餘的石子數

        if (t < 0)
        {
            break;
        }

        if (f[t] == -1)
        {
            f[t] = mex(t);
        }

        g[f[t]] = 1;
    }

    for (i = 0; ; i++)
    {
        if (!g[i])   //得到sg值
        {
            return i;
        }
    }
}

int main()
{
    void Sort(int a[], int k);

    while (scanf("%d", &k), k) //逗號表達式最右邊的子表達式的值即爲逗號表達式的值。
    {
        int i;
        int m;       //m種情況
        int s;       //異或值

        for (i = 0; i < k; i++)
        {
            scanf("%d", &S[i]);
        }

        Sort(S, k);

        memset(f, -1, sizeof(f));
        f[0] = 0;

        scanf("%d", &m);

        while (m--)
        {
            int l;       //每行的堆數
            int t;      //每堆的石子數 hi

            scanf("%d", &l);
            s = 0;

            while (l--)
            {
                scanf("%d", &t);

                if (f[t] == -1)    //如果sg值不存在
                {
                    f[t] = mex(t);  //f[t] 賦予sg值
                }

                s = s^f[t];
            }

            if (s == 0)
            {
                printf("L");
            }
            else
            {
                printf("W");
            }
        }

        printf("\n");
    }
    return 0;
}

//冒泡排序
void Sort(int a[], int K)
{
    int i;
    int j;
    int t;

    for (i = 0; i < K - 1; i++)
    {
        t = i;

        for (j = i + 1; j < K; j++)
        {
            if (a[t] > a[j])
            {
                t = j;
            }
        }

        if (t != i)
        {
            int temp;
            temp = a[t];
            a[t] = a[i];
            a[i] = temp;
        }

    }
}


 


 

 

           

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章