PAT 1142 Maximal Clique圖論

原文鏈接:我的個人博客

原題描述

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))
Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.
After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

考點

  圖論,完全連通圖

思路

  這題直接暴力就可以解決。先判斷對於輸入的點是不是任意兩個頂點都相鄰。再判斷這些點以外的所有點是否存在有的點和輸入的點全部相連。最後即可判斷是不是最大的完全圖了

代碼

#include <bits/stdc++.h>
using namespace std;
int e[510][510],ne,nv,m,k;
bool has[510];
void type(vector<int> v){
    for(int i=0;i<v.size()-1;i++){
        for(int j=i+1;j<v.size();j++){
            if(e[v[i]][v[j]]==0){
                printf("Not a Clique\n");
                return;
            }
        }
    }
    for(int i=1;i<=ne;i++){
        if(has[i]==false){
            int flag = 0;
            for(int j=0;j<v.size();j++){
                if(e[i][v[j]]==0){
                    flag = 1;
                    break;
                }
            }
            if(flag==0){ 
                printf("Not Maximal\n");
                return; 
            }
        }
    }
    printf("Yes\n");
}
int main(){
    cin>>ne>>nv;
    for(int i=0;i<nv;i++){
        int a,b;
        cin>>a>>b;
        e[a][b]=e[b][a]=1;
    } 
    cin>>m;
    for(int i=0;i<m;i++){
        cin>>k;
        vector<int>v;
        fill(has,has+510,false);
        for(int j=0;j<k;j++){
            int tmp;
            cin>>tmp;
            has[tmp] = true;
            v.push_back(tmp);
        }
        type(v);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章