hdu 1385 Minimum Transport Cost(輸出最短路的路徑)

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2649    Accepted Submission(s): 651

Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0

 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
           這題是一道很好的題目:輸出最短路路徑,方法:記錄每一點的前一個點爲多少,用floyd的話就是要二維了。
代碼:
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <queue>
using namespace std;

const int INF = 99999999;
const int N = 505;

int map[N][N], tax[N], path[N][N];
int n;

void init()
{
    int i, j;
    for(i = 1; i <= n; i++)
        for(j = 1; j <= n; j++)
            if(i == j) map[i][j] = 0;
            else map[i][j] = INF;
}

void input()
{
    int i, j, k;
    for(i = 1; i <= n; i++)
        for(j = 1; j <= n; j++)
        {
            scanf("%d", &k);
            if(k != -1) map[i][j] = k;
            path[i][j] = j;
        }
    for(i = 1; i <= n; i++)
        scanf("%d", &tax[i]);
}

void floyd()
{
    int i, j, k, len;
    for(k = 1; k <= n; k++)
    {
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
            {
                len = map[i][k] + map[k][j] + tax[k];
                if(map[i][j] > len)
                {
                    map[i][j] = len;
                    path[i][j] = path[i][k];    //標記到該點的前一個點
                }
                else if(len == map[i][j])   //若距離相同
                {
                    if(path[i][j] > path[i][k]) //判斷是否爲字典順序
                        path[i][j] = path[i][k];
                }
            }
        }
    }
}

void output()
{
    int i, j, k;
    while(scanf("%d %d", &i, &j))
    {
        if(i == -1 && j == -1) break;
        printf("From %d to %d :\n", i, j);
        printf("Path: %d", i);
        k = i;
        while(k != j)   //輸出路徑從起點直至終點
        {
            printf("-->%d", path[k][j]);
            k = path[k][j];
        }
        printf("\n");
        printf("Total cost : %d\n\n", map[i][j]);
    }
}

int main()
{
    while(scanf("%d", &n), n)
    {
        init();
        input();
        floyd();
        output();
    }

    return 0;
}
 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章