hdu 2577 How to Type(很爽很好玩的DP)

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 842    Accepted Submission(s): 364

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.

 

Sample Input
3 Pirates HDUacm HDUACM

 

Sample Output
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 
            題目大意:給你一個字符串,問要至少按多少次鍵盤才能打出這些字母,有大寫和小寫,可以按caps lock,也可以按shift。注意!!最後打完後,caps lock一定要是關燈的(小寫)。
         一道很好的DP題目!非常好!用on[]記住開燈的狀態,用off[]記住關燈的狀態,然後根據大小寫字母來寫狀態轉移方程!下面代碼有詳細註釋。
代碼:
#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;

char ch[105];
int on[105];    //打開大寫
int off[105];   //關閉大寫

int main()
{
    int i, t, len;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s", ch);
        len = strlen(ch);
        off[0] = 0; //剛開始的沒開燈
        on[0] = 1;  //開燈的要+1
        for(i = 0; i < len; i++)
        {
            if(ch[i] >= 'a' && ch[i] <= 'z')    //小寫字母
            {
                //開:(開~~shift+type, 關~~type+開燈)
                on[i+1] = min(on[i] + 2, off[i] + 2);
                //關:(開~~lock+type, 關~~type)
                off[i+1] = min(on[i] + 2, off[i] + 1);
            }
            else    //大寫字母
            {
                //開:(開~~type, 關~~開燈+type)
                on[i+1] = min(on[i] + 1, off[i] + 2);
                //關:(開~~lock+type, 關~~shift+type)
                off[i+1] = min(on[i] + 2, off[i] + 2);
            }
        }
        on[len]++;
        printf("%d\n", min(on[len], off[len]));
    }

    return 0;
}
 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章