HDU 1856 More is better 並查集

More is better
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 23649    Accepted Submission(s): 8516


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.


Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)


Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 


Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


Sample Output
4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAXN 100000*2
int Par[MAXN], Rank[MAXN];
void Init(int n)
{
    for (int i = 1;i <= n;i++)
    {
        Par[i] = i;
        Rank[i] = 0;
    }
}
int Find(int x)
{
    if (Par[x] == x) return x;
    else return Par[x] = Find(Par[x]); ///同時壓縮路徑
}
void Unite(int x, int y)
{
    x = Find(x);y = Find(y);
    if (x == y) return;
    if (Rank[x]<Rank[y]) Par[x] = y;
    else Par[y] = x;
    if (Rank[x] == Rank[y]) Rank[x]++;
}
int main(void)
{
    //freopen("F:\\test.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        Init(100000);
        for(int i=1,a,b;i<=n&&scanf("%d %d",&a,&b);i++)
            Unite(a,b);
        for(int i=1;i<=100000;i++)  Par[i] = Find(i);//全部更新一下祖先 sort(Par+1,Par+1+100000);  int Max = 1,Count = 1,Last = Find(1);
        for(int i=2;i<=100000;i++)
        {
            int now = Par[i];
            if(now == Last) Count ++;
            else
            {
                Max = max(Count,Max);
                Last = now;
                Count = 1;
            }
        }
        Max = max(Count,Max);   //最後一組數據處理//判定最大的朋友圈
        printf("%d\n",Max);
    }


}

來源: http://acm.hdu.edu.cn/showproblem.php?pid=1856

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章