母函數的運算

F - Ignatius and the Princess III
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 
 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 
 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 
 

Sample Input

4 10 20
 

Sample Output

5 42 627
瞭解了定義,感覺做題也有了感覺了呢。
“母函數的思想很簡單—就是把離散數列冪級數一一對應起來,把離散數列間的相互結合關係對應成爲冪級數間的運算關係,最後由冪級數形式來確定離散數列的構造. “
我們首先來看下這個多項式乘法: (以下圖片都可以點擊放大)
母函數詳解

母函數詳解

由此可以看出:
1.x的係數是a1,a2,…an 的單個組合的全體。
2. x2的係數是a1,a2,…a2的兩個組合的全體。
………
n. xn的係數是a1,a2,….an的n個組合的全體(只有1個)。
#include<stdio.h>
#include<string.h>
int main()
{
    int a,i,j,k;
    int sum1[10010],sum2[10002];
    while(~scanf("%d",&a))
    {
        for(i=0;i<=a;i++)
        {
        sum1[i]=1;//初始化一個數組,並且定義爲1,由於自身的原因。
        sum2[i]=0;//另定義的一個數組,便於下面計算
        }
        for(i=2;i<=a;i++)
        {
            for(j=0;j<=a;j++)
            for(k=0;k+j<=a;k+=i)
            sum2[k+j]+=sum1[j];//將每次所滿足的一次結果存入sum2數組中
            for(j=0;j<=a;j++)
            {
                sum1[j]=sum2[j];//將每次所得結果存入sum1中,
                sum2[j]=0;//對um2進行清零。便於下次計算。
            }
        }
        printf("%d\n",sum1[a]);//輸出結果。
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章