09-1. Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -

分析:这道题就是一道用平方探测法处理哈希函数的题,但是该题只能正增长,所以平方探测法hash_func(hash_func(key) + j *j)
hash_func表示计算存放哈希表下标的函数,这里用了嵌套,先计算出第一次应该存放的位置,然后按平方增长
还有要注意一下的就是素数,就应该没有什么问题了。

源码:

#include<iostream>
#include<cmath>

using namespace std;

//哈希表结构
struct Hash{
	bool *flag;		//数组
	int MSize;		//数组长度
};
//判断素数
bool isPrime(int n){
	if (n == 1)
		return false;
	if (n == 2)
		return true;
	for (int i = 2; i <= sqrt(n); i++){
		if (n%i == 0)
			return false;
	}
	return true;
}
//构造哈希表
Hash *CreateHash(int MSize){
	Hash *H = new Hash;
	while (!isPrime(MSize)){			//找大于MSize的最小的素数
		MSize++;
	}
	H->flag = new bool[MSize];		//创建数组
	H->MSize = MSize;
	for (int i = 0; i < MSize; i++){	//初始化
		H->flag[i] = false;
	}
	return H;
}



//哈希函数
int HashFunc(int key, int MSize){
	return key%MSize;
}

int main()
{
	int MSize, N;
	cin >> MSize >> N;
	Hash *H;
	H = CreateHash(MSize);
	for (int i = 0;i < N; i++){
		int number;
		bool Flag = false;       //判断是否插入
		cin >> number;
		for (int j = 0; j < N; j++){
			//int pos = HashFunc(HashFunc(number, H->MSize) + j * j, H->MSize);
			int pos = HashFunc(number, H->MSize);
			if (!H->flag[pos]){
				if (i == N - 1)
					cout << pos;
				else cout << pos << " ";			
				H->flag[pos] = true;
				Flag = true;
				break;
			}
		}
		if (!Flag){
			if (i == N - 1)
				cout << "-";
			else
				cout << "- ";
		}
	}

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章