The Suspects POJ 1611

The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

題意: 0號必然感染,和0號一組的是感染者,還有這一組中的去其他人也會去感染其他人,然後問你最多有多少感染者

題解:有一個技巧就是初始化是t[i]=1;在mix()函數中相加。需要注意此題最少有一個人。

#include<stdio.h>
int road[10000000+10];
int t[10000000+10]; 
int find(int a)
{
    if(road[a]==a) return a;
    else
    return road[a]=find(road[a]);
}
void mix(int a,int b)
{

    int x;
    int y;
    x=find(a);
    y=find(b);
    if(x!=y)
    {
        road[y]=x;
        t[x]+=t[y];//是兩個集合連接在一起,並使人數相加
    }

}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    if(n==0&&m==0)
    {
        break;
    }
    else
    {
        int a, b,c,maxx=0;
        for(int i=0;i<=n;i++)
        {
            road[i]=i;
            t[i]=1;
        }
        while(m--)
        {

            scanf("%d",&a);
            scanf("%d",&b);
            for(int i=0;i<a-1;i++)
            {
                scanf("%d",&c);
                mix(c,b);
            }
        }
        int MAX=0;  
        MAX=t[find(0)];
        printf("%d\n",MAX);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章