POJ - 2407 Relatives

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16494   Accepted: 8368

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

Source

Waterloo local 2002.07.01

利用歐拉函數和它本身不同質因數的關係,用篩法計算出某個範圍內所有數的歐拉函數值。

  歐拉函數和它本身不同質因數的關係:歐拉函數ψ(N)=N{∏p|N}(1-1/p)。(P是數N的質因數)

  如:

  ψ(10)=10×(1-1/2)×(1-1/5)=4;

  ψ(30)=30×(1-1/2)×(1-1/3)×(1-1/5)=8;

  ψ(49)=49×(1-1/7)=42。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
using namespace std;
int fun(int n){
	int ans=n;
	for(int i=2;i<=sqrt(n);i++){
		if(n%i==0){
			ans=ans/i*(i-1);
			while(n%i==0){
				n=n/i;
			}
		}
	}
	if(n>1){
		ans=ans/n*(n-1);
	}
	return ans;
}
int main(){
	int n;
	while(cin>>n&&n){
		 int ans=fun(n);
		 cout<<ans<<endl;
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章