PAT1004 Counting Leaves(30)(BFS,DFS,树的层序遍历)

类型:树的遍历,dfs

题目:

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

分析题目

可怜英语不好,题目都看不懂,先查一下一些单词
family hierarchy家谱 pedigree tree谱系树
For the sake of simplicity为了简单起见
seniority排行

好了单词查完了,大概了解了题目意思,输入端首先第一行给一个N表示树的总节点个数,第二个数M表示non-leaf node个数,后面每一行就表示所有non-leaf的结构,最终输出每一层叶子节点的个数

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> v[100];
int book[100];
int maxdepth = -1;
void dfs(int index, int depth)
{
    if(v[index].size() == 0)
    {
        maxdepth = max(depth, maxdepth);
        book[depth]++;
        return;
    }
    for(int i=0; i<v[index].size(); i++)
    {
        dfs(v[index][i], depth+1);
    }
}

int main()
{
    int N, M;
    cin >> N >> M;
    for(int i = 0; i<M; i++)
    {
        int index, childnum;
        cin >> index >> childnum;
        for(int j = 0; j<childnum; j++)
        {
            int child;
            cin >> child;
            v[index].push_back(child);
        }
    }
    dfs(1, 0);
    int k = 0;
    for(k=0; k<maxdepth; k++)
    {
        cout << book[k] << " ";
    }
    cout << book[k];
    return 0;
}

总结

其实是一道简单的dfs题目,复习了一下dfs的操作,参考了柳神的代码

还可以~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章