HDU1305(Immediate Decodability)

Immediate Decodability

Problem Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable

思路

题目大概意思就是判断一个字符串是不是其他字符串的前缀。直接上字典树 或者 map。字典树做法就是给前缀数目统计,并且给字符串进行标记。如果一个前缀次数 >= 2次同时这个前缀是一个字符串就不满足,否则就满足。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 100005;
int num[maxn];
int trie[maxn][2];
bool f[maxn];
int cnt;
void insert_s(char *s)
{
	int n = strlen(s);
	int root = 0;
	for(int i = 0;i < n;i++){
		int k = s[i] - '0';
		if(!trie[root][k]){
			trie[root][k] = ++cnt;
		}
		root = trie[root][k];
		num[root]++;
	}
	f[root] = true;
}
int main()
{
	char s[15];
	int k = 1;
	while(~scanf("%s",s)){
		cnt = 0;
		memset(trie,0,sizeof(trie));
		memset(f,false,sizeof(f));
		memset(num,0,sizeof(num));
		insert_s(s);
		while(~scanf("%s",s)){
			if(s[0] == '9')		break;
			insert_s(s);
		}
		bool flag = true;
		for(int i = 1;i <= cnt;i++){
			if(num[i] >= 2 && f[i]){
				flag = false;
				break;
			}
		}
		if(flag){
			printf("Set %d is immediately decodable\n",k++);
		}
		else{
			printf("Set %d is not immediately decodable\n",k++);
		}
	}
	return 0;
}

愿你走出半生,归来仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章