HDU1671(Phone List)

Phone List

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

  1. Emergency 911
  2. Alice 97 625 999
  3. Bob 91 12 54 26
    In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

思路

題目大概意思就是判斷一個號碼是不是其他號碼的前綴。直接上字典樹 或者 map。字典樹做法就是給前綴數目統計,並且給號碼進行標記。如果一個前綴次數 >= 2次同時這個前綴是一個號碼,那麼輸出NO,否則輸出YES。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <map>
using namespace std;
const int maxn = 100005;
int trie[maxn][10];
int num[maxn];
bool f[maxn];
int cnt;
void insert_s(string s)
{
	int n = s.length();
	int root = 0;
	for(int i = 0;i < n;i++){
		int k = s[i] - '0';
		if(!trie[root][k]){
			trie[root][k] = ++cnt;
		}
		root = trie[root][k];
		num[root]++;
	}
	f[root] = true;
}
int main()
{
	int t,n;
	cin >> t;
	while(t--){
		cin >> n;
		string s;
		cnt = 0;
		memset(trie,0,sizeof(trie));
		memset(f,false,sizeof(f));
		memset(num,0,sizeof(num));
		for(int i = 0;i < n;i++){
			cin >> s;
			insert_s(s);
		}
		bool flag = true;
		for(int i = 1;i <= cnt;i++){
			if(num[i] >= 2 && f[i]){			//前綴數目 >= 2,同時這個前綴是一個號碼。
				flag = false;
			}
		}
		if(flag){
			cout << "YES" << endl;
		}
		else{
			cout << "NO" << endl;
		}
	}
	return 0;
} 

願你走出半生,歸來仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章