poj 1703(並查集)

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20441   Accepted: 6052

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source



題目類型:並查集

題目描述:一個城市中只有兩個犯罪團伙,告訴你某個罪犯和某個罪犯不在一個團伙。然後問你兩個罪犯之間的關係。

題目分析:既然只有兩個團伙,那麼罪犯不在這個團伙就在那個團伙中。用 foe[i] 記錄第一個與 i 不在一個團伙的人的 id。
這樣如果a,b不在一個團伙,那麼a和foe[b]肯定在一個團伙,同理b和foe[a]肯定在一個團伙。接下來就非常簡單了,同一個集合中的元素團伙一樣,把團伙一樣的集合合併。


代碼如下:
#include <iostream>
#include <stdio.h>
#define N 100005
using namespace std;

int rank[N];
int foe[N];
int f[N];
int n;
void init(){
    for(int i = 1; i <= n ; i++){
        rank[i] = 0;
        foe[i] = -1;
        f[i] = i;
    }
}

int find(int x){
    if( x == f[x]) {
        return x;
    } else {
        return f[x] = find(f[x]);
    }
}


void merge(int a, int b){
    int ra = find(a);
    int rb = find(b);
    if(ra != rb){
        if(rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[rb] == rank[ra]){
                rank[ra]++;
            }
        }
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){

        int m;
        scanf("%d%d",&n,&m);
        init();

        char command;
        int a;
        int b;
        for(int i = 0; i < m;i++){
            getchar();
            command = getchar();
            scanf("%d%d",&a,&b);
            if( command == 'A') {
                if( find(a) == find(b)){
                    printf("In the same gang.\n");
                } else {
                    if( foe[a] == -1 || foe[b] == -1 || find(a) != find(foe[b])){
                        printf("Not sure yet.\n");
                    } else {
                        printf("In different gangs.\n");
                    }
                }

            } else {
                if(foe[a] == -1){
                    foe[a] = b;
                }
                if(foe[b] == -1){
                    foe[b] = a;
                }
                merge(a,foe[b]);
                merge(b,foe[a]);
            }
        }
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章